[Therion] Therion fails to compile with vtk 6

Olly Betts olly at survex.com
Mon Dec 15 23:14:30 CET 2014

On Sun, Dec 14, 2014 at 08:23:23PM -0600, Bill Gee wrote:
> Thanks for the reply.  I downloaded the patch file vtk6.patch and tried to 
> apply it to the Therion 5.3.15 source tree.  It looks like the first part 
> worked but not the second.  Here is the output from patch:
> ===============
> [bgee at main2 therion]$ patch -p1 -i vtk6.patch 
> patching file loch/lxData.cxx
> Hunk #1 succeeded at 540 (offset 5 lines).
> Hunk #2 succeeded at 582 (offset 5 lines).
> patching file loch/Makefile
> Hunk #1 FAILED at 37.
> 1 out of 1 hunk FAILED -- saving rejects to file loch/Makefile.rej
> [bgee at main2 therion]$ 
> ==================
> If I try to compile this, it goes further than before but still fails while 
> processing loch.  It appears to still be looking for vtk libraries in the 
> vtk-5.4 directory.

That's probably just a consequence of the changes to loch/Makefile not
getting applied (since that's where those libraries are specified),
which is probably because some earlier patch in the huge pile we're now
carrying also changed that area of that file.

If you look at loch/Makefile.rej, you can probably make the required
changes to loch/Makefile by hand.

Alternatively, applying all the patches in the order given in the series
file should work - you can get quilt to do that with:

QUILT_PATCHES=/path/to/debian/patches quilt push -a


More information about the Therion mailing list