[Therion] Therion fails to compile with vtk 6

Bill Gee bgee at campercaver.net
Mon Dec 15 03:23:23 CET 2014


Hi Olly -

Thanks for the reply.  I downloaded the patch file vtk6.patch and tried to 
apply it to the Therion 5.3.15 source tree.  It looks like the first part 
worked but not the second.  Here is the output from patch:

===============
[bgee at main2 therion]$ patch -p1 -i vtk6.patch 
patching file loch/lxData.cxx
Hunk #1 succeeded at 540 (offset 5 lines).
Hunk #2 succeeded at 582 (offset 5 lines).
patching file loch/Makefile
Hunk #1 FAILED at 37.
1 out of 1 hunk FAILED -- saving rejects to file loch/Makefile.rej
[bgee at main2 therion]$ 
==================

If I try to compile this, it goes further than before but still fails while 
processing loch.  It appears to still be looking for vtk libraries in the 
vtk-5.4 directory.

Regards - Bill Gee


On Thursday, December 11, 2014 19:57:00 Olly Betts wrote:
> On Thu, Dec 11, 2014 at 12:42:24PM -0600, Bill Gee wrote:
> > Based on this it appears to me that major changes have been made
> > between vtk 5 and 6.   Eventually I am sure other people will run into
> > this problem.
> 
> I already fixed this for the Debian package - you can find a patch here:
> 
> http://sources.debian.net/src/therion/5.3.15-2/debian/patches/vtk6.patch/
> 
> It would be great if more of the patches we're carrying in Debian got
> merged so that others didn't hit these same problems and have to try to
> fix them again for themselves:
> 
> http://sources.debian.net/src/therion/5.3.15-2/debian/patches/
> 
> If there's anything Wookey or I can do to help get them merged, please
> say.
> 
> Cheers,
>     Olly




More information about the Therion mailing list