[Therion] Therion fails to compile with vtk 6

Bill Gee bgee at campercaver.net
Tue Dec 16 02:32:53 CET 2014


Hi Olly -

That sounds a bit like the roads around here!  They are well known for having 
a patch on top of a patch on top of a patch.  

I took a stab at changing the loch Makefile manually.  It still fails, but now 
it has yet another message.  Here is the last few bits from the compile run.

==================
gcc -c -Wall -D_GNU_SOURCE -DLOCH -DLXLINUX  -I/usr/lib64/wx/include/gtk2-
unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -
D_LARGE_FILES -D__WXGTK__ -pthread  -o .././loch/img.o img.c
c++ -o .././loch/loch -Wall .././loch/lxR2P.o .././loch/lxTR.o 
.././loch/lxOGLFT.o .././loch/lxSetup.o .././loch/lxRender.o .././loch/lxWX.o 
.././loch/lxImgIO.o .././loch/lxLRUD.o .././loch/lxFile.o .././loch/lxSTree.o 
.././loch/lxData.o .././loch/lxMath.o .././loch/lxSView.o .././loch/lxSScene.o 
.././loch/lxGUI.o .././loch/lxGLC.o .././loch/lxOptDlg.o 
.././loch/lxAboutDlg.o .././loch/img.o -lwx_gtk2u_gl-2.8 -pthread -Wl,-z,relro   
-lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -
lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -
lwx_baseu_xml-2.8 -lwx_baseu_net-2.8 -lwx_baseu-2.8  -L/usr/lib/vtk-5.4 -
lvtkCommonExecutionModel-6.1 -lvtkCommonDataModel-6.1 -lvtkCommonCore-6.1 -
lvtkFiltersCore-6.1 -lvtkFiltersHybrid-6.1 -lvtkIOLegacy-6.1 -lfreetype -lGLU 
-lpthread -lz  -s
/usr/bin/ld: cannot find -lvtkCommonExecutionModel-6.1
/usr/bin/ld: cannot find -lvtkCommonDataModel-6.1
/usr/bin/ld: cannot find -lvtkCommonCore-6.1
/usr/bin/ld: cannot find -lvtkFiltersCore-6.1
/usr/bin/ld: cannot find -lvtkFiltersHybrid-6.1
/usr/bin/ld: cannot find -lvtkIOLegacy-6.1
collect2: error: ld returned 1 exit status
make[1]: *** [.././loch/loch] Error 1
make[1]: Leaving directory `/home/bgee/Installs/therion/loch'
make: *** [loch/loch] Error 2
======================

I noticed a section at the top of the Loch Makefile where it is using some tcl 
programs to find where vtk is installed.  This starts on line 14.  On my 
systems the three tcl programs return data as if vtk 5.4 were installed.  The 
system has no trace of vtk 5.4 left on it.  The two directories returned for 
VTKPATH and VTKLIBPATH do not exist.  Will this cause any problems?

Thanks - Bill Gee


On Monday, December 15, 2014 22:14:30 Olly Betts wrote:
> On Sun, Dec 14, 2014 at 08:23:23PM -0600, Bill Gee wrote:
> > Thanks for the reply.  I downloaded the patch file vtk6.patch and tried to
> > apply it to the Therion 5.3.15 source tree.  It looks like the first part
> > worked but not the second.  Here is the output from patch:
> > 
> > ===============
> > [bgee at main2 therion]$ patch -p1 -i vtk6.patch
> > patching file loch/lxData.cxx
> > Hunk #1 succeeded at 540 (offset 5 lines).
> > Hunk #2 succeeded at 582 (offset 5 lines).
> > patching file loch/Makefile
> > Hunk #1 FAILED at 37.
> > 1 out of 1 hunk FAILED -- saving rejects to file loch/Makefile.rej
> > [bgee at main2 therion]$
> > ==================
> > 
> > If I try to compile this, it goes further than before but still fails
> > while
> > processing loch.  It appears to still be looking for vtk libraries in the
> > vtk-5.4 directory.
> 
> That's probably just a consequence of the changes to loch/Makefile not
> getting applied (since that's where those libraries are specified),
> which is probably because some earlier patch in the huge pile we're now
> carrying also changed that area of that file.
> 
> If you look at loch/Makefile.rej, you can probably make the required
> changes to loch/Makefile by hand.
> 
> Alternatively, applying all the patches in the order given in the series
> file should work - you can get quilt to do that with:
> 
> QUILT_PATCHES=/path/to/debian/patches quilt push -a
> 
> Cheers,
>     Olly




More information about the Therion mailing list