[Therion] make samples qmarks is broken

Stacho Mudrak s.m at group-s.sk
Tue May 5 09:09:45 CEST 2009


Are you able to run loch from gdb and find out source code line where it fails?

I have a suspicion, that it may be off-screen rendering stuff that is
doing problems. It is initialized when loch starts. On some machines
(especially linux with intel graphic cards), it segfaults when I try
to render off-screen, but may be on some other, it can not even
initialize. Especially when you are able to run all wx open-gl
samples.

Regards, S.

On Tue, May 5, 2009 at 5:47 AM, Martin Luethi <luethi at vaw.baug.ethz.ch> wrote:
> Wookey
>
> Wookey writes:
>  > > So it all build nicely, however loch just segfaults for me.
>
> Had was bugging the mailing list about the loch segfault more than a year
> ago. I never could resolve it, and nobody else could. There was some
> indication that this might be due to some Intel Graphics card driver problem.
>
> Your strace looks very much like mine, and there was this "resource
> temporarily unavailable" that might be the culprit. Somehow some X capability
> (DRI) cannot be accessed.
>
> Once upon a time everything worked perfectly, but never since then. If you
> have any ideas how to further debug that I would be glad to hear that. Since I
> am not a graphics person I have now clue how to fix that. Also, all wx
> examples and other wx applications worked nicely, so that I am not shure
> whether wx is used in a wrong way.
>
> Maybe valgrind could help, but I havn't done that yet.
>
> Best, Martin
>
> _______________________________________________
> Therion mailing list
> Therion at speleo.sk
> http://mailman.speleo.sk/mailman/listinfo/therion
>



More information about the Therion mailing list