[Therion] make samples qmarks is broken

Martin Luethi luethi at vaw.baug.ethz.ch
Tue May 5 05:47:12 CEST 2009


Wookey writes:
 > > So it all build nicely, however loch just segfaults for me.

Had was bugging the mailing list about the loch segfault more than a year
ago. I never could resolve it, and nobody else could. There was some
indication that this might be due to some Intel Graphics card driver problem.

Your strace looks very much like mine, and there was this "resource
temporarily unavailable" that might be the culprit. Somehow some X capability
(DRI) cannot be accessed. 

Once upon a time everything worked perfectly, but never since then. If you
have any ideas how to further debug that I would be glad to hear that. Since I
am not a graphics person I have now clue how to fix that. Also, all wx
examples and other wx applications worked nicely, so that I am not shure
whether wx is used in a wrong way.

Maybe valgrind could help, but I havn't done that yet.

Best, Martin

More information about the Therion mailing list