[Therion] MacOSX error and solution: ImageMagick after upgrading from Mt.Lion to Mavericks

Martin Sluka martinsluka at mac.com
Sat Feb 21 20:55:26 CET 2015


It is not so simple, check:

http://stackoverflow.com/questions/22715738/imagemagick-error

This worked at the end:

xxxxxxxxxxxxxxxxxxxxxx
brew unlink jpeg
brew link jpeg

Then reinstall imagemagick from source

brew uninstall imagemagick
brew install imagemagick --build-from-source

Now you can check if jpeg is in the delegate

identify -list configure | grep DELEGATES

It should have jpeg now

DELEGATES bzlib mpeg freetype jng jpeg lcms lzma png tiff xml zlib
xxxxxxxxxxxxxxxxxxxxxx

m.

> 21. 2. 2015 v 20:40, Martin Sluka <martinsluka at mac.com>:
> 
> To generate Thbook with all samples is necessary to convert pdf files from samples directory. But in Maverick or Yosemite there is error when installing ImageMagick by Brew:
> 
> Why is ImageMagick trying to load JPG coder at /usr/local/Cellar/imagemagick/6.8.8-9/lib/ImageMagick//modules-Q16/coders/jpeg.la? Why the double slash after ImageMagick// ?
> 
> I came across this issue too when upgrading from Mt.Lion to Mavericks. I found an issue in homebrew's github repo. 
> 
> The fix that worked for me was:
> 
> $ brew uninstall imagemagick
> $ brew install imagemagick --build-from-source
> 
> m.
> _______________________________________________
> Therion mailing list
> Therion at speleo.sk
> http://mailman.speleo.sk/mailman/listinfo/therion




More information about the Therion mailing list