[Therion] Background images and insert images not working

Wookey wookey at wookware.org
Fri Dec 27 02:37:44 CET 2013


+++ cawa sorix [2013-12-25 17:25 +0100]:
> >> Do we believe that
> >> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=718294
> >> is fixed in 5.3.12?
> 
> I updated my Sid and I have this bug with 5.3.12 same as 5.3.11
> 
> To reproduce it you have to use an existing th2 file with a link to an
> existing image, you can open it on stable debian version but on Sid,
> the background image is not visible and when you try to add an image
> it crash. :'(

Aha - it hapens on jessie and sid, but not wheezy. OK. I can reproduce now. Cheers Cawa.

Something to do with the libtk-img package perhaps, as that's
responsible for adding tck/tk png support. It's installed.
http://packages.qa.debian.org/libt/libtk-img.html shows that it changed
from 1.3 to 1.4  between stale (wheezy) and testing (jessie), which sugests that 1.3 works and 1.4 doesn't.
SImply reverting to v1.3 doesn't fix it, but maybe it's need to be rebuilt agianst the corresponding headers too?

So trying to insert background in a new (empty) .th2 file gives:
ag "command" doesn't match any items
tag "command" doesn't match any items
    while executing
"$xth(me,can) lower $xth(me,imgs,$imgx,image) command"
    (procedure "xth_me_image_insert" line 201)
    invoked from within
"xth_me_image_insert $xth(ctrl,me,images,newposx) $xth(ctrl,me,images,newposy) {} 0 {}"
    ("uplevel" body line 4)
    invoked from within
"uplevel \#0 $cmd"
    (procedure "Button::_release" line 23)
    invoked from within
"Button::_release .xth.me.af.ctrl.cf11.f.ic.insp"
    (command bound to event).

Taking a file that should have an image already such as  initially
doesn't show the background image, but adding a second one makes it 
appear in the list in the UI twice, and the just-inserted one displays
correctly.

Closing the file now cuases this error:
an't unset "xth(me,imgs,0,name)": no such element in array
can't unset "xth(me,imgs,0,name)": no such element in array
    while executing
xth_me_image_destroy_all"
    (procedure "xth_me_destroy_file" line 13)
    invoked from within
"xth_me_destroy_file"
    (procedure "xth_me_close_file" line 12)
    invoked from within
"xth_me_close_file"
    invoked from within
".xth.#xth#me#menu.#xth#me#menu#file invoke active"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke active]"
    (procedure "tk::MenuInvoke" line 50)
    invoked from within
"tk::MenuInvoke .xth.#xth#me#menu.#xth#me#menu#file 1"
    (command bound to event)

This looks to me like the image file is not 'initialised' somehow until a second one is read in.

I don;t have much idea how this works, so will send thisin in the hope that someone who speaks tcl/tk can see what's up.

Wookey

-- 
Principal hats:  Linaro, Emdebian, Wookware, Balloonboard, ARM
http://wookware.org/



More information about the Therion mailing list