problem importing .3d file

Wookey wookey at
Tue Feb 8 04:05:52 CET 2005

+++ Stacho Mudrak [05-02-07 16:19 +0100]:

>> It was dirty bug, but it should be fixed now. I have put new
>> developement snapshot on the downloads page. Your sample seems to works now.

Thanx again for the speedy fixes. Downloaded, built, and tested.

Something very odd happenned the first time I ran it. It seemed to run
through lots of data, looking like everything was fixed andthen it came up
with a 'duplicate survey error - dummy' error. It turned out that this was
due to the thconfig file being 'doubled' - it had had a second copy of
itself added to the end (thus including twice, hence the duplicate
survey error).

However having fixed that it now seems to process OK, so I'm not sure if
this is a bug or finger trouble on my part, but I'm fairly sure I didn't
mess it up.

However - whilst it now processes a 'null' set of data as in the example, as
soon as I put back any data it goes wrong again:
input goon.th2
(inside the terikan survey) and I get:
therion: error -- terikan/goon.th2 [10] -- survey does not exist -- goon --
invalid station reference -- 69 at goon

Now it doesn't seem to matter whether the terikan.3d file is included inside
or outside the terikan survey context, or even not included at all - I get
the same erro in each case.

The .3d file is being read because I get a cave.3d file out that looks fine
(i.e. looks just the same as the terikan.3d file).

So - any clues? You can test this by just uncommenting line 47 of the
20050207 dataset you have.

Aleph One Ltd, Bottisham, CAMBRIDGE, CB5 9BA, UK Tel +44 (0) 1223 811679
work: play:

More information about the Therion mailing list