Wook's persistent Therion bug

Wookey wookey at aleph1.co.uk
Mon Jun 28 15:57:23 CEST 2004

+++ Stacho Mudrak [04-06-22 10:12 +0200]:

>> After reading your file several time, it seems to be very simple error. You
>> are missing survey command in the beginning of your file :))) Change your
>> file to following:
>> encoding utf-8
>> survey soundriver
>> [current file contents]

OK, you're right. That line must have got deleted at some point.

So, it was a silly error, but given that this has taken some 6 weeks to
solve with some fairly computer-savvy users, it suggests that the error
messages could be rather more helpful.

If it had said: "'survey' command missing before 'map' command", or "data
must be enclosed in 'survey' at line blah", then we might have worked it out
a bit quicker than 'invalid command context' which didn't help either of us,
and so we started suspecting something complicated and looking through
hex-dumps of the file! (this wasn't helped by my mistaken belief that it
worked OK with 0.2.19 - sorry about that - "bloody users!").

>> It's very simple - in fact all therion commands must be placed between
>> survey - endsurvey commands (survey context). And all 2D commands (point,
>> line, area) must be placed between scrap - endscrap commands (scrap
>> context). I'll send you your data files (once you have sent them to us)
>> that work correctly. You can diff with your files to see the difference.

OK - so it shouldn't be too hard to generate a much more user-helpful
message when this doesn't happen.

>> Thanks for your feedback, I hope it will work now (at least the files I
>> will send you).

Yep - I'm back in business. I'll upload therion 0.3.1 today and try and get
some drawing done soon...

Aleph One Ltd, Bottisham, CAMBRIDGE, CB5 9BA, UK Tel +44 (0) 1223 811679
work: http://www.aleph1.co.uk/ play: http://www.chaos.org.uk/~wookey/

More information about the Therion mailing list