So, yes I think I agree that wall and wall-blocks should both be types, but wall-blocks-presumed possibly shouldn't be.
OK, but I've never seen in any cave symbol list "presumed wall probably formed by blocks" :))), but I've seen many times "presumed wall" or something simmilar - so I think wall-presumed will be enought. And in any case - for each combination of type/subtype - you need a separate symbol. Therefore I think we need only types... Another point - wall-invisible or wall -subtype invisible is completely not realistic. Therefore it should be probably renamed to outline or something like this...
Theother thing to consider is the interface. Exactly how we specify the data is probably a bit arbitrary,
Yes, I've intention to change it in any case - the combobox is not very lucky solution. S.