[Therion] fixed point std error causes extreme survey network distortion

Bruce bruce at tomo.co.nz
Fri Dec 27 08:18:18 CET 2013


Below a conversation transcript that I took briefly ‘off forum’, but now
time to post it I think.

 

You can read from the bottom of the transcript below if you are interested.

 

Briefly in summary, it seems to me that since 5.3.5 or earlier, therion loop
closure results in grossly distorted outputs IF there are two or more fixed
stations AND (only?) for the stations that have standard errors specified
AND there are survey networks connecting those fixed stations.  Specifying
Survex loop closure bypassed this problem.

 

Since I installed Survex 1.2.8 a few weeks agoi, my machine has been giving;

“C:\Program Files\Therion\therion.exe: warning -- can't open cavern output”

when survex loop closure is specified, and I suspect this is causing Therion
to revert to therion loop closure and hence the distortion problem has been
manifesting again if I specify std errors.  You can see samples of  my
therion.log files in the attached dataset.

Xavier is using Survex 1.2.6 and his log files, which do not have this
problem, are attached separately.

 

If you are interested you can experiment with the fixed station statements
in the INDEX file in the attached dataset to see what effect various
adjustments have.  You might also have to adjust the loop-closure statement
in therion.ini.

 

So two things to fix; Therions loop closures and Survex 1.2.8 integration
with Therion.

 

Bruce

 

 

 

  _____  

From: Bruce [mailto:bruce at tomo.co.nz] 
Sent: Friday, 27 December 2013 8:47 a.m.
To: 'Xavier Pennec'
Subject: fixed point std error causes extreme survey network distortion

 

As commented below.

Bruce

  _____  

From: Xavier Pennec [mailto:Xavier.Pennec at inria.fr] 
Sent: Friday, 27 December 2013 12:48 a.m.
To: Bruce Mutton
Subject: Re: fixed point std error causes extreme survey network distortion

 

Hi Bruce,

I just compiled as is and did not get any distortion. However, I have survex
installed: I vaguely remember having some problems using the therion
loop-closure algorithm with some uncertainty on the fixed points a long time
ago (actually problems when survex is not installed, which amounts to using
the therion loop-closure engine).  Way back in time this was the reason I
first installed Survex – I had similar problem with elevations (this one
seems mainly a plan problem however)

And then later I had this problem that I posted on the forum

http://article.gmane.org/gmane.comp.gis.therion/2378/match=loop+closure

Indeed, activating therion loop closure (using "loop-closure therion" in the
therion.ini file) distorts the cave 
. This might be a side effect of the
loop-closure problem that you reported in 2010 (link above) and which is
still unsolved apparently. Based on past experience this is what I was
expecting, but my current therion.ini is ‘default’ and therion.log reports
survex activity, so it seems for me both survex and therion loop closures
are now giving me this effect (5.3.11 and 5.3.12 it seems).  I have tried
editing therion.ini to explicitly force both types of loop closure, and the
log file reflects what I specify, but the output is always distorted when
there are two or more fixed points and at least one has std errors
specified.

With therion loop-closure, I get as well with my data some "scraps too
large" errors to produce the pdf output. Same (but also for Survex closure
for me)

Thus, we can conclude to a bug in therion loop-closure. (Historically I
agree, but I am perplexed as to why I now get it with Survex loop closure as
well.  I have searched my machine and cannot find any rogue therion.ini
files that might be causing the problem.  The log file reports the correct
initialization file.  Perhaps there is a clue in the log file entry
“C:\Program Files\Therion\therion.exe: warning -- can't open cavern output”
Maybe this is causing my machine to revert back to therion loop closure in
all cases?)




Xavier

Le 26/12/2013 02:48, Bruce a écrit :

Hi Xavier




 

I’ve managed to replicate the problem I’ve been having with standard errors
on fixed points in this small dataset.  It is a cave survey I have been
using as a training exercise with prospective Therion users – and
consequently not finished, and has some strange things in it.  


 

Interested to see if you get the same problems I am getting.

The dataset as attached manifests the problem.  I have noticed that if std
errors are specified for a particular fixed station, and if the ‘loop
closure’ required is not almost exactly zero, then that particular fixed
point is displaced significantly from what it should be.

 

You can experiment with this at the start of the file INDEXHunters.th

If you comment out the second fix statement you can see what the cave should
look like.

(oriented roughly east-west) 

If you compile the attached ‘as is’ and you get an output that looks like
this, then you are not experiencing my problem.  When I compile the
attached, the western entrance is shifted some 300m to the north so that the
cave is oriented roughly north south.  Not sure, but the problem seems to be
related to ‘loop closure’ in ‘north-south’ direction but not ‘east-west’.  I
think I may have had a similar effect in the vertical direction years ago,
and installing Survex (changing loop closure algorithm) fixed it.

 

Open the Hunters3DModel.3d and turn on fixed points, entrances and surface
surveys to get an overview of the structure of the survey.

 

Anyway, what happens for you?  Distortion or not?

Is there anything different in my dataset arrangement that might be causing
this? (ie My map definitions in hunters.th are outside of the survey
definition).

 

Thanks for any insights you might have.

Bruce

 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.speleo.sk/pipermail/therion/attachments/20131227/7af997b9/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: th_HuntersLoopTest.zip
Type: application/x-zip-compressed
Size: 235672 bytes
Desc: th_HuntersLoopTest.zip
URL: <http://mailman.speleo.sk/pipermail/therion/attachments/20131227/7af997b9/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: therion_with_Therion_loop-closure-Xavier.log
Type: application/octet-stream
Size: 4742 bytes
Desc: therion_with_Therion_loop-closure-Xavier.log
URL: <http://mailman.speleo.sk/pipermail/therion/attachments/20131227/7af997b9/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: therion_withSurvex-Xavier.log
Type: application/octet-stream
Size: 6704 bytes
Desc: therion_withSurvex-Xavier.log
URL: <http://mailman.speleo.sk/pipermail/therion/attachments/20131227/7af997b9/attachment-0001.obj>


More information about the Therion mailing list