[Therion] New file error

Andrew Atkinson andrew at wotcc.org.uk
Wed Sep 19 19:46:25 CEST 2012


I have just discovered a frightening bug

If you hit the new file icon (as I did accidental because my menus had
disappeared. as I tried to open the file menu) the object window on the
right is cleared, but not the picture. (So when I first did this I did
not notice, and carried on, only noticing when I tried to compile it and
it failed but I had over written my file by then, thank you version
control, only lost half an hours work.)

Anyway, recreating this, it appears that after you have hit new file
(the icon) the Object window is cleared, and if you then click on a line
or point in the drawing window, it adds an end of file and then the
object appears after the end of file, item number -1. anything else
click continues to be added as -1. trying to click on these objects in
the object window, gives an error (I was hoping to move them to the
right side of the end of file). Adding new items go in the right place
and then anything clicked on is put in the right place but still with a
-1 number, selecting this in the object window puts in a new end of file
line, directly after it, therefore loosing everything else.

I have attached a screen shot that hopefully show a bit of what I mean.

Therion 5.2.9 on Debian whizzy

Andrew


-------------- next part --------------
A non-text attachment was scrubbed...
Name: Items outside of file.png
Type: image/png
Size: 96115 bytes
Desc: not available
URL: <http://mailman.speleo.sk/pipermail/therion/attachments/20120919/947e3540/attachment.png>


More information about the Therion mailing list