[Therion] Error on using undo - cannot break the resulting loop

Bruce bruce at tomo.co.nz
Fri Jun 22 22:15:27 CEST 2012


Spectacular crash Andrew.
Is Xtherion permanently broken on your machine or was it just a problem for
that session?

Regardless I don't have any insights sorry.
Any similar (but much less comprehensive) errors I have had always resolved
themselves in a well behaved manner.
Bruce

-----Original Message-----
From: therion-bounces at speleo.sk [mailto:therion-bounces at speleo.sk] On Behalf
Of Andrew Atkinson
Sent: Friday, 22 June 2012 7:19 p.m.
To: List for Therion users
Subject: [Therion] Error on using undo - cannot break the resulting loop

Hello

I tried the savannah bug site, but although I thought I had a log in, I
seem not to, or have completely forgotten it. So I tried to register,
but the capcha would not let me past, kept getting this error

Please correctly answer the antispam captcha! Bad passphrase (not enough
different characters or classes for this length) Warning: Savane was not
able to read "" site-specific information, please contact administrators

I am sure I did not get them all wrong, I even did the audio, to confirm
on a few of them.

Anyway onto the therion error.

While drawing a rock-border, I tried to follow a couple of wall points,
then decided against it, (I might have managed to end the line, but
double clicking, but not sure about this)
Did a couple of undos with crtl-z and got the error

can't read "xth(me,cmds,22,8,x)": no such element in array
can't read "xth(me,cmds,22,8,x)": no such element in array
    while executing
"set ox $xth(me,cmds,$id,$pid,x)"
    (procedure "xth_me_cmds_update_line" line 12)
    invoked from within
"xth_me_cmds_update_line $id $pid $xth(ctrl,me,line,type)
$xth(ctrl,me,line,name) $xth(ctrl,me,line,opts)
$xth(ctrl,me,line,reverse) $xth(ctrl,me,lin..."
    (procedure "xth_me_cmds_update" line 28)
    invoked from within
"xth_me_cmds_update {}"
    (procedure "xth_me_unredo_undo" line 4)
    invoked from within
"xth_me_unredo_undo"
    (procedure "xth_app_control_z" line 7)
    invoked from within
"xth_app_control_z"
    (command bound to event)

Also the menus have disappeared, (not sure if this is related)

After this all I can find that I can do is move the page with right
click, and change between the 3 windows using the icons or the function
keys. I can open and close files in the data and configuration windows,
and edit the text in all windows. Everything else I try give the same
error above, whichever window I am in. I cannot even close, with the
cross icon or alt-F4.

Andrew
_______________________________________________
Therion mailing list
Therion at speleo.sk
http://mailman.speleo.sk/mailman/listinfo/therion




More information about the Therion mailing list