[therion-users] simple HOWTO

Wookey wookey at aleph1.co.uk
Tue Dec 3 15:36:53 CET 2002


Sorry - I deleted the original message, but you wrote:

> Until some manual to xtherion will come, you can do following simple steps:
> 
> 1. Go to map editor
> 2. File->New
> 3. Press Insert button in Background images control panel
> 4. Open some *.gif (limitation of tcl/tk) file
> 5. Press "Auto adjust" button in Drawing area control panel
> 6. Open File commands control panel
> 7. Select "Action" -> Insert scrap
> 8. Press created "Insert scrap" button
> 9. click on "scrap1" in file commands list box
> 10. set "projection" to none in scrap control panel
> 11. press Control+L (or Edit -> Insert line)
> 12. draw close line (couter-clockwise oriented ;-) by clicking the last
> point on the first point
> 13. save the file as test.th2
> 
> Now an export of this simple map should work, if you will type folloving
> thconfig file
> 
> source test.th2
> export map none
> 
> If this will work, then the lesson 2 will come. But probably you'll
> understand a lot of things from this simple example...


That was very helpful. I do now basically understand how it works, except
for how to set the scale for a scrap (and exactly what that means), and how
to relate the picture to the real stations.

I'm in a hurry so here are some hasty notes. I hope it is enough to help me
along a bit further.

However it didn't quite work:
compile failed with test.th2[26] -
invalid command context, because the line was outside the scrap context.
(all the lines are above the 'scrap' entry).
Even if you move this line to top so line is enclosed by scrap you still get
same error.
Adding a survey enclosure gets us 'no selected projection data'

I also put in a proper survey to relate to some real data:
But that wouldn't produce output either:
 If you use same name in station label as station in .th file e.g. '5'
 point x y station -station 5
 then survey data specifying station 5 gvies an erro 'object exists -- 5'
 Change one (e.g. to '05') and data compiles but then says 'projection
 extended - no reference station' - how is this made to work?

So I am stuck again and still haven't quite managed to produce any ouput. I
need another clue. 'lesson 2' :-)

Do I need to post sample files?

I also found a lot of other things that were problems for the new user. You
probably know about these but I'll record them here anyway as a useful
feedback:

* Errors in compiler go off screen RH side - wrap them?
* Lots of stuff cannot be read in RH side panels (eg point types) - widen box,
 shrink font, make pop-up show current text not truncate it to fit (I
shrank the font from 12 to 9 pt in the xtherion tcl script and that was a
lot better on a 1024x768 screen). Once you know all the options it doesn't
matter so much but to start with it is hopeless - you can only see the
first 7-8 characters or so.
 
* More keyboard shortcuts - may exist already?

* If you add a scrap manually then set the projection in xtherion and save 
it doesn't add it. You need to delete scrap and redo in xtherion.

* projection command/object doesn't seem to be recognised - you need the
-projection option for the scrap command instead.

* How do I set the scale for a scrap? what does 'update scale' do?

* F1 etc don't work if menu currently selected. (tcl limitation? - quite
annoying)

* Problem with files being updated in two places at once. eg edit thconfig
in text editor but version in compiler is not changed. If you close one in
compiler to force an update it overwrites the version on disk. Needs to
check modification times or something slightly smarter. Similar prob with
edits made in text editor and in map editor at same time.


Wookey
-- 
Aleph One Ltd, Bottisham, CAMBRIDGE, CB5 9BA, UK  Tel +44 (0) 1223 811679
work: http://www.aleph1.co.uk/     play: http://www.chaos.org.uk/~wookey/






More information about the Therion mailing list